MySQL- Руководство разработчика



              

MySQLdb: Python-интерфейс для MySQL


MySQLdb представляет собой поточно-совместимый интерфейс с популярной СУБД MySQL, который обеспечивает Python API для баз данных. Здесь рассматривается его версия 0.9.1 (автор Andy Dustman, andy@dustman.net). Пакет распространяется по лицензии GPL и доступен для закачки с http://sourceforge.net/projects/mysql-python. Цели проекта:

  • Совместимость с Python API для баз данных (версия 2.0).
  • Поточно-безопасная работа.
  • Потоки теперь не будет блокировать друг друга.
  • Совместимость с MySQL-3.23 и выше.

Требования:

Python 1.5.2 или выше:

  • http://www.python.org
  • Версии ниже, чем 1.5.2, НЕ РАБОТАЮТ.
  • Все версии, начиная с 1.5.2, работать должны. 1.6.x не тестировались. 2.0.1, 2.1.1 и 2.2a3 были протестированы успешно.
  • Если Вы имеете Red Hat Linux или подобную систему установки пакетов, надлежит установить бибилотеки и заголовки разработчика для Python (python-devel). Для версий Python-2.x это python2-devel.

Distutils 1.0.2 или выше:

  • Поставляется с Python 1.6 и выше.
  • 1.0.2 включена в Python version 2.1 и выше.
  • http://www.python.org/sigs/distutils-sig/download.html

MySQL 3.22.19 или выше.

  • http://www.mysql.com/downloads
  • Версии ниже, чем 3.22 точно НЕ РАБОТАЮТ.
  • Версии ниже, чем 3.22.19 могут не работать.
  • MySQL-4.0 поддерживается.
  • MySQL-3.23 поддерживается.
  • Если Вы имеете Red Hat Linux или подобную систему установки пакетов, надлежит установить бибилотеки и заголовки разработчика для MySQL. Если Вы используете пакеты с mysql.com, Вам нужен пакет MySQL-devel. Если Вы используете пакеты Red Hat, Вам нужен mysql-devel. Я предпочитаю пакеты с сайта www.mysql.com.




Содержание  Назад  Вперед